home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / linux-wlan-ng-firmware-0.2.2 / linux-wlan-ng-firmware-0.2.2.ebuild < prev    next >
Text File  |  2006-03-31  |  1KB  |  52 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-firmware/linux-wlan-ng-firmware-0.2.2.ebuild,v 1.6 2005/12/18 22:47:46 betelgeuse Exp $
  4.  
  5. inherit eutils
  6.  
  7. MY_P=${P/-firmware/}
  8.  
  9. DESCRIPTION="Firmware for Prism2/2.5/3 based 802.11b wireless LAN products"
  10. HOMEPAGE="http://linux-wlan.org"
  11. SRC_URI="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/${MY_P}.tar.bz2"
  12.  
  13. LICENSE="MPL-1.1 Conexant-firmware"
  14. SLOT="0"
  15. KEYWORDS="~amd64 ~ppc ~x86"
  16.  
  17. IUSE=""
  18.  
  19. DEPEND=""
  20. RDEPEND=""
  21.  
  22. S=${WORKDIR}/${MY_P}
  23.  
  24. src_unpack() {
  25.     unpack ${A}
  26.     epatch ${FILESDIR}/prism2_makefile-${PV}.patch
  27. }
  28.  
  29. src_compile() {
  30.     local config=${S}/config.mk
  31.     echo TARGET_ROOT_ON_HOST=${D} >> ${config}
  32.     echo FIRMWARE_DIR=/lib/firmware >> ${config}
  33. }
  34.  
  35. src_install() {
  36.     cd ${S}/src/prism2
  37.     make install-firmware || die "Failed to install firmware"
  38. }
  39.  
  40. pkg_postinst() {
  41.     einfo "Firmware location has changed to ${ROOT}lib/firmware."
  42.     einfo "You can run emerge --config =${PF} to delete"
  43.     einfo "The old files. Because of the default configuration file"
  44.     einfo "protection, the files are most likely left your system"
  45.     einfo "and are now useless."
  46. }
  47.  
  48. pkg_config() {
  49.     rm -i ${ROOT}/etc/wlan/*.hex
  50.     rm -i ${ROOT}/etc/wlan/*.pda
  51. }
  52.